WCF Logo e código de barra

Jul 4, 2013 at 1:38 PM
Edited Jul 4, 2013 at 1:56 PM
Bom dia , tudo bem com vocês?

Bom, estou criando um gerador de boletos e realizei todas as tarefas pra gerar localmente.
O meu chefe pediu pra implementar o WCF só que a logo e código de barra não está aparecendo aqui.

A primeira imagem foi no debug na qual mostra logo e código de barra
Image

A segunda imagem é sem a logo e código de barra.
Image


No web.config do meu serviço e cliente coloquei dessa forma.
<httpHandlers>
      <remove verb="*" path="*.asmx"/>
      <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
      <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
      <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false"/>
      <add verb="*" path="ImagemCodigoBarra.ashx" validate="false" type="BoletoNet.ImagemCodigoBarraHandler"/>
    </httpHandlers>
Tentei pegar todas as imagens e colocar no meu projeto de WCF e retirei o "C:\~~\~~\AppData\Local\Temp\"
e também não consegui obter sucesso.

Como posso fazer pra exibir?
Jul 8, 2013 at 4:55 PM
Boa tarde, consegui solucionar em partes o problema no Google Chrome não funciona por que as imagens não ficam dentro do arquivo temporário e funciona no IE, descobri isso depois de ler o que alguns colegas postaram,

Só que agora meu problema é que ao passar no leitor de código de barra não reconhece.

Alguém poderia me auxiliar?
Developer
Jul 10, 2013 at 2:05 AM
Boa noite, Kaiseriver.
Verifique as dimensões da sua impressão. Normalmente, quando o leitor laser não consegue identificar o código de barras, é porque a distância mínima entre uma barra e outra está errada. Tire as medidas da sua impressão, ou seja do código de barras e acerte-o se for necessário. Atenção, o problema é só a impressão, ok?
Espero ter ajudado, abraços.
Jul 10, 2013 at 12:30 PM
Na verdade eu verifiquei aqui que só acontece quando uso o "montaHtml" aquece uma pequena distorção da imagem do código de barra, porém se eu usar "MontaHtmlNoArquivoLocal" salva o arquivo corretamente com a imagem código de barra.

Muito obrigado.

Agora estou com dificuldades de implementar o bancoob e sicredi, se eu consegui implementar coloco aqui e adiciono a biblioteca.